
T
he most heralded new features in Adobe 
Photoshop 5.0 are Color Management, Editable 
Text, Layer Effects, and of course, Adobe’s answer 
to years (seems like decades) of user requests for

unlimited “undos.” Let’s step back from the marketing
hype and cut to the chase—the History palette,
together with the History Brush, will fundamentally
change the way you work with images. If you are a
creative professional who experiments with an image
as you go, does a lot of retouching, or designs screens
and interfaces for multimedia or the Web, the History
palette is as important an addition to Photoshop as the
addition of Layers was to Photoshop 3.0 back in 1994. 

I’m not saying that the History palette will make
you younger, richer, or more popular (it isn’t perfect—
yet). But learning to think like the History palette takes
at most a few hours; once you’ve invested that time,
you’ll never want to work without it.

How it Works
The History palette keeps track of recent changes made

to an image. You can step back to or revert to any state
(or part of the state) listed in the History palette by:

• clicking on the state in the History palette;
• using the History Brush to brush back from one

state to another;
• painting from the History Snapshot;
• making and saving Duplicate Files; or
• filling with History.
Before we begin, let’s take a look at the History

palette options (Window>Show History>History Options).
The Maximum History States option is the number of
steps the History palette will track (one to 100); the
Automatically Create First Snapshot option ensures that
the software records a snapshot of the first frame; the Allow

Non-Linear History option allows you to undo a state
and try a new version of the image while the previous
states remain available for reference (Figure 2). 

The number of states you allow Photoshop to track
depends on the computer’s RAM and how many steps
you are comfortable reverting to. The History palette
tracks only changes to actual pixels, and tracking a
small brush stroke takes up an insignificant amount of
memory compared to tracking a mode conversion. The
History palette does not track such Photoshop
navigation as zooming, scrolling, and selecting tools.

Let’s say you used Adobe’s default for Maximum
History States, which is 20. When you have completed
the 21st step, the first step is pushed out of the History
buffer and replaced by the original step number two.
You can set this default as high as 100, depending on
how far back in the History you may need to go. More
important, you can discard History states you don’t
need. For example, say you’ve just retouched a photo
with the Rubber Stamp tool, making eight passes with
the Rubber Stamp to get an area just right. To you, the
cloning procedure felt like one function, but the History
palette lists eight clone strokes. By discarding all of the
clone steps except for the most recent, you can free
space in the History palette and continue working.

The other two options, Automatically Create First
Snapshot and Allow Non-Linear History, should be
checked as a default. Allow Non-Linear History is such
an important setting that I will demonstrate the
consequences of not using it with a step-by-step
description of the image “Cupid in Doorway.”

Non-Linear History
We’ll walk through the basics of the History

palette. In the first part of the imaging process,
I’ll work with the Adobe default settings (which 
do not have Allow Non-Linear History checked). 
As I add layers and effects to the image, the
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History palette records what I have done. (Figure 3). 
Note: You don’t have to have the History Palette open

while doing the image editing; it will keep track in the
background. To access the History palette, just tap F9 on
your keyboard and click on the History Palette tab. 

You can step back to a previous state of the image by
clicking on it with the mouse or using the command keys
(cmd/ctrl-option/alt-Z); conversely, you can step forward
through the History (cmd/ctrl-option/alt-shift-Z). In this
case, I add the cupid and then decide to step backward—
so far so good. But when I add an Image Adjustment
layer after the Gaussian Blur (Figure 5), the cupid steps

disappear. Even if I move back to the Gaussian Blur step,
the cupid does not reappear. Where is it? Cupid has fallen
victim to my not checking Allow Non-Linear History.

Now I’ll change the setting to what I think should be
the default in History Options—Allow Non-Linear
History—and I’ll bring in Cupid again. Let’s look at the
difference in the History Palette (Figure 8).

Now when I step backward, the History states listed be-
low the active state have remained dark. And when I con-
tinue with the image, the next step is placed at the bottom
of the History list and does not overwrite existing states.

Clicking on the desired state is the most straightforward
method of working with the History Palette. Remember
to check Allow Non-Linear History and use the History
Palette to go backward and forward through the
imaging process. 

The History Brush
The second method of working with History is to use

the History Brush (Press the Quick key “Y” to access it).
To tell Photoshop which History to paint from, click next
to the desired state and paint on a layer that existed during
that state of History. This is where the History brush
can get a little confusing; you have to paint onto a layer
that existed and was affected by the history change that
you are painting from, or you will get the frustrating
universal NO symbol (circled in red in Figure 11).

The NO symbol signifies that you are trying to paint
between incompatible states. The most common type of
incompatibility occurs when you try to paint from a
History state onto a layer that did not exist when that
History state was recorded (which is really too bad,
since I would love to be able to paint with History onto
an empty layer to keep original data and History data
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separate). Additional History trip-ups, include resizing,
cropping, and changing modes. I get around these traps by
planning ahead (i.e., after cropping or changing modes,
I either save or duplicate the file and continue working).

The best thing about using the History Brush is that it
uses the same Blend Mode options as all the brushes.
For example, you can brush Lighten back in after
running a Gaussian Blur filter to add a very effective
touch of light ghosting. 
The History Snapshot

Using the History Snapshot is the best way to work
with the History Palette. It is straightforward and
works every time (you won’t get that irritating NO
symbol). I’ll create a wake-up call image with two stock
photos and use the History Snapshot to work back and
forth between different stages of the image with the
History Brush. At the bottom of the History Palette,
there are three icons that perform specific tasks when
clicked: Duplicate File, Take Snapshot, and Trash
(Figure 12). 

There are three instances when I would recommend

taking a History Snapshot:
• when you have come to a version of the image

that you will want to refer to later;
• when you have created a version that you like,

but you want to continue to experiment without
losing it; 

• and when you have created a step in the image
from which you will need information to finish 
your image. 

For example, when retouching an image, you can
combine blurred and sharpened layers with opposing
Lighten and Darken blend modes to soften skin and at
the same time bring out details in the eyes. I would
take a snapshot of the blurred image and then a
snapshot of the sharpened image and use the History
Brush to work between the two states.

To create the wake-up image, I dragged the alarm clock
onto the sunrise image. As soon as I had the clock in
position, I took a snapshot by clicking the Take Snapshot
button. It is essential to remember to take a snapshot
at important steps of an image. In this case, I thought I
might want to later refer to the sharp version of the clock.

I blurred the clock with the Zoom Blur and took

another snapshot (Figure 14). I now have three
versions of the image to work with: original
background, sharp clock, and blurred clock 
(I also added an artificial cloud layer to increase the
mood of the image). When you have made your
snapshots, double-click on the History Brush, and let
the fun begin! (Figure 14)

By clicking next to any of the History Snapshots, I
can paint from that History state, going back and
forth between sharp and blurred clock faces. In this
case, I set the History Brush to Lighten to bring back
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the lightest contours of the sharp clock and leave a
glow in the darker areas (Figure 15).

To add impact to the image, I selected the clock face
with a feathered elliptical Marquee, created a new layer
with it, spherized it, and took another snapshot (Figure 16).
You may wonder why I didn’t simply spherize the layer
without making a new layer, and then take a snapshot.
Fact is, once I close the image, the History States and
Snapshots are wiped. Because I may want to refer to the
non-spherized clock face layer, it is prudent to work with
the advantages of Layers. To add the final touch, I
brought back some of the original sunrise from the first
snapshot so that it looks as if the clock and sky are merging. 

Note: Name your snapshots! Late at night all those little
pictures can start looking the same.

Making and Saving Duplicate Files
There are a number of ways to duplicate a file in

Photoshop. For example, you can choose File>Save a
Copy, Image>Duplicate, or click on the Duplicate File
icon at the bottom of the History Palette. I use the
History Duplicate File function when designing screens
for presentations or the Web. It’s a quick way to
duplicate files with all layers intact, while I continue to
design and experiment. In the following example, the
screens were designed for a half-day seminar on digital
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imaging. By the time the design team was finished with
all the screens, we had used six Photoshop files with 100
layers each. By using History Duplicate, I can duplicate
the entire file, with all the layers (but not the History), and
change only the text on the layers with the editable text
option (Figure 18). In this example, I applied a layer effect
to the editable text, and when I typed in the new text, the
layer effect was already on it. I can either keep working
on the original or the duplicate, or I can save it to a
work-in-progress folder.

You can also duplicate snapshots by dragging the
Snapshot icon  down to the Duplicate button (Figure
21). Use this when you are about to quit an imaging
session, but want to save some of the snapshots for
future use. By making a duplicate from a snapshot and
saving the file, you are working around the reality that
Snapshots and History are wiped clean when you close
the file (or quit Photoshop, or crash the computer . . . ).

Filling with History
It’s happened to all of us—you’re working away on

an image, retouching an area, and when you zoom
back out, you see that the retouched area doesn’t fit the
image at all. Selecting an area and filling it with History

is a quick way to revert to a certain part of the image
quickly or to replace part of the image with a better
rendition. Fill With History is accessible under the
Edit>Fill menu.

The Darker Side of History
The History palette has three drawbacks; the first of

which requires an investment—RAM. Keeping track of
History takes a lot of RAM; Adobe recommends a
minimum of 32MB to start up Photoshop 5.0, twice as
much as they recommended for 4.0. The amount of
RAM required to run the History palette is affected by
these variables: the size of the image; how many
History states you allow Photoshop to track; and what
you do to the image (e.g., the History of a brush stroke
takes less memory than the History of filtering a layer
that contains lots of image data).

The second drawback of the History Palette is that—
although it is an incredibly seductive feature, offering
instant gratification—you have to remember that you
are editing the image pixels. Once you save and close
the image, those pixels are gone. I really like the
History palette, but I am very careful in deciding when
to use it, and when it will be better to use either a
separate Layer or a Layer mask to hide or reveal image
data. The biggest advantage of using layers with layer
masks is that the pixel information is still accessible
and editable once the image has been saved and the file
closed. When using the History Palette, you can save
the file without losing the History, but once you close
the file . . . hasta la vista, pixels!

The third drawback of the History palette is
something that I’ve got to believe Adobe is already
working on: It is not possible to save and/or apply a
History to another image. Once you close the image,
the History is wiped and you cannot access it again.
Believe me, I have tried holding down every possible
key combination to export the History of an image. If
you know how to do it, please e-mail me (address).

The Future of History is here, and once you
understand how it works, there is no turning back.
Since I started working with Photoshop 5.0, I am much
more inclined to experiment with an image, knowing
that the History palette is watching and noting what
I’m doing. As a result, my images have become less
linear, and I feel as if I am painting with the
photographs rather than manipulating them, an
approach that’s constructive rather than destructive. So
make those snapshots, and dive into your History. §

bio??
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